Skai Social Platform Partially Unavailable
Incident Report for Skai
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 19:27 UTC
Investigating
Some Skai Social users are experiencing an issue logging into our platform.
Our team is investigating the issue.
Posted Mar 19, 2024 - 18:43 UTC
This incident affected: Platform Availability (Meta).