Amazon Advertising API Performance Data
Incident Report for Skai
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 18:07 UTC
Monitoring
In collaboration with Amazon, we have deployed solutions to stabilize the Amazon Advertising API scaling issues. As a result, performance data for Amazon Advertising users should now appear as expected in Kenshoo. We will continue to monitor progress closely and provide an update once this incident is fully resolved. Please work with your Client Success team or submit a ticket to our support team if you are experiencing any issues.
Posted May 28, 2021 - 17:44 UTC
Update
We are continuing to investigate this issue.
Posted May 28, 2021 - 16:43 UTC
Update
We are still experiencing Amazon Advertising API scaling issues, affecting most Kenshoo Ecomm users. Performance data is delayed and/or missing, impacting metrics such as Impressions, Clicks, Cost, Ad Revenue and ROAS. We are working closely with Amazon on this matter and will follow up with more details as soon as possible.
Workarounds: Users can use the Amazon Advertising console (i.e., native UI) to report intraday performance. Please stay tuned for more updates as our engineering and Client Success teams work towards resolving this issue.
Posted May 27, 2021 - 20:25 UTC
Investigating
We identified an Amazon Advertising API scaling issue originating on Amazon's end, affecting some Kenshoo Ecomm users. Performance data pulls will be throttled down until Amazon can increase scale to meet demand for the increased number of API calls. We're working with Amazon on this issue and will follow up with more details as soon as possible.
Workarounds: Users can use the Amazon Advertising console (i.e., native UI) to report intraday performance.
Posted May 26, 2021 - 23:04 UTC
This incident affected: Skai Retail Media Interface (Publisher, Data, Reports, Optimization, Campaign Management).